TYPO3 4.7.x – HTML5 Doctype

Sollte man sein Doctype von XHTML auf HTML5 ändern, muss ab der Version 4.7.x darauf geachtet werden, dass die richtige Schreibweise benützt wird. In meinem Beispiel hab ich eine TYPO3 Version Abfrage in den Konstanten eingebaut.

### Constants
doctype = html_5

### TYPO3 >= 4.7
[compatVersion => 4.7]
	doctype = html5
[global]

### Setup
config {	
	doctype = {$doctype}
	xmlprologue = none
	xhtml_cleaning = none
	htmlTag_setParams = none
}

1 Kommentar

  1. Sven Burkert
    26.02.2013

    Ich recherchiere gerade nach compatVersion und welche Vergleichsoperatoren möglich sind. In TYPO3 4.5 scheint nur “=” möglich zu sein, denn bei der Bedingung [compatVersion => 4.7] gibt die verarbeitende Funktion “true” zurück.

Hinterlassen Sie eine Antwort

Kontakt
Do NOT follow this link or you will be banned from the site!